XStore Theme Requirements

Before using XStore, you first need to make certain that your server and WordPress meets the theme’s requirements, including  WordPress version 3.9+. Most  problems, such as white screen after theme installation, out of memory errors, fails when import demo content, etc., are usually related to server settings and excessively low PHP configuration limits. You can change them by yourself, or contact your hosting provider and request the limits be increased to the following minimums:  

  • file_get_contents() function should be enabled in the server configuration;
  • PHP version: 5.3 or higher;
  • OpenSSL system library: 1.0 version, or higher;
  • max_execution_time:   180, or greater;
  • memory_limit:  128M, or greater;
  • upload_max_filesize: 40M, or greater.

Use the WordPress php info plugin to check your PHP configuration limits.